# CVE-2020-5274: Exceptions displayed in non-debug configurations in Symfony

> Attackers can view sensitive exception details and stack traces in production environments due to improper escaping and display logic in Symfony's ErrorHandler.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-symfony-2020-5274, DEBIAN-CVE-2020-5274, GHSA-m884-279h-32v2

## What is CVE-2020-5274?

CVE-2020-5274 is a medium-severity vulnerability in Sensiolabs Symfony, published on 30 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Symfony before versions 5.0.5 and 4.4.5, some properties of the Exception were not properly escaped when the `ErrorHandler` rendered it stacktrace. In addition, the stacktrace were displayed even in a non-debug configuration. The ErrorHandler now escape alls properties of the exception, and the stacktrace is only display in debug configuration. This issue is patched in symfony/http-foundation versions 4.4.5 and 5.0.5

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2020-5274?

9 open source packages ship an affected version, including symfony/error-handler, symfony and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/error-handler` | Packagist | From 4.4.0 | 4.4.4 |
| `symfony/error-handler` | Packagist | From 4.4.0 | 4.4.4 |
| `symfony/error-handler` | Packagist | From 5.0.0 | 5.0.4 |
| `symfony/error-handler` | Packagist | From 5.0.0 | 5.0.4 |
| `symfony` | Bitnami | From 4.4.0 | 4.4.4, 5.0.4 |
| `symfony/symfony` | Packagist | From 4.4.0 | 4.4.4 |
| `symfony/symfony` | Packagist | From 4.4.0 | 4.4.4 |
| `symfony/symfony` | Packagist | From 5.0.0 | 5.0.4 |
| `symfony/symfony` | Packagist | From 5.0.0 | 5.0.4 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2020-5274?

Upgrade symfony/error-handler to a fixed version for your release line: 4.4.4 or 5.0.4.

## Is CVE-2020-5274 being exploited?

There is no known exploitation of CVE-2020-5274 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5274 and fix it if it is affected.

What it is: CVE-2020-5274 is a medium-severity vulnerability in Sensiolabs Symfony, published on 30 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5274 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/error-handler (Packagist): affected from 4.4.0; fixed in 4.4.4
- symfony/error-handler (Packagist): affected from 4.4.0; fixed in 4.4.4
- symfony/error-handler (Packagist): affected from 5.0.0; fixed in 5.0.4
- symfony/error-handler (Packagist): affected from 5.0.0; fixed in 5.0.4
- symfony (Bitnami): affected from 4.4.0; fixed in 4.4.4, 5.0.4
- symfony/symfony (Packagist): affected from 4.4.0; fixed in 4.4.4
- symfony/symfony (Packagist): affected from 4.4.0; fixed in 4.4.4
- symfony/symfony (Packagist): affected from 5.0.0; fixed in 5.0.4
- symfony/symfony (Packagist): affected from 5.0.0; fixed in 5.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5274/ (Markdown: https://insights.sbomify.com/CVE-2020-5274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5274
- OSV: https://osv.dev/vulnerability/CVE-2020-5274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5274/
Summaries are generated and may contain mistakes; the official description above is the record.
