# CVE-2020-5275: Firewall configured with unanimous strategy was not actually unanimous in symfony/security-http

> Attackers can bypass access controls in Symfony applications using the unanimous firewall strategy due to premature access decision granting.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-symfony-2020-5275, DEBIAN-CVE-2020-5275, GHSA-g4m9-5hpf-hx72

## What is CVE-2020-5275?

CVE-2020-5275 is a high-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 30 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In symfony/security-http before versions 4.4.7 and 5.0.7, when a `Firewall` checks access control rule, it iterate overs each rule's attributes and stops as soon as the accessDecisionManager decides to grant access on the attribute, preventing the check of next attributes that should have been take into account in an unanimous strategy. The accessDecisionManager is now called with all attributes at once, allowing the unanimous strategy being applied on each attribute. This issue is patched in versions 4.4.7 and 5.0.7.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-5275?

13 open source packages ship an affected version, including symfony/security, symfony and symfony/security-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security` | Packagist | From 4.4.0 | 4.4.7 |
| `symfony/security` | Packagist | From 4.4.0 | 4.4.7 |
| `symfony/security` | Packagist | From 5.0.0 | 5.0.7 |
| `symfony/security` | Packagist | From 5.0.0 | 5.0.7 |
| `symfony` | Bitnami | From 4.4.0 | 4.4.7, 5.0.7 |
| `symfony/security-http` | Packagist | From 4.4.0 | 4.4.7 |
| `symfony/security-http` | Packagist | From 4.4.0 | 4.4.7 |
| `symfony/security-http` | Packagist | From 5.0.0 | 5.0.7 |
| `symfony/security-http` | Packagist | From 5.0.0 | 5.0.7 |
| `symfony/symfony` | Packagist | From 4.4.0 | 4.4.7 |
| `symfony/symfony` | Packagist | From 4.4.0 | 4.4.7 |
| `symfony/symfony` | Packagist | From 5.0.0 | 5.0.7 |
| `symfony/symfony` | Packagist | From 5.0.0 | 5.0.7 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2020-5275?

Upgrade symfony/security to a fixed version for your release line: 4.4.7 or 5.0.7.

## Is CVE-2020-5275 being exploited?

There is no known exploitation of CVE-2020-5275 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5275 and fix it if it is affected.

What it is: CVE-2020-5275 is a high-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 30 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5275 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security (Packagist): affected from 4.4.0; fixed in 4.4.7
- symfony/security (Packagist): affected from 4.4.0; fixed in 4.4.7
- symfony/security (Packagist): affected from 5.0.0; fixed in 5.0.7
- symfony/security (Packagist): affected from 5.0.0; fixed in 5.0.7
- symfony (Bitnami): affected from 4.4.0; fixed in 4.4.7, 5.0.7
- symfony/security-http (Packagist): affected from 4.4.0; fixed in 4.4.7
- symfony/security-http (Packagist): affected from 4.4.0; fixed in 4.4.7
- symfony/security-http (Packagist): affected from 5.0.0; fixed in 5.0.7
- symfony/security-http (Packagist): affected from 5.0.0; fixed in 5.0.7
- symfony/symfony (Packagist): affected from 4.4.0; fixed in 4.4.7
- symfony/symfony (Packagist): affected from 4.4.0; fixed in 4.4.7
- symfony/symfony (Packagist): affected from 5.0.0; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5275/ (Markdown: https://insights.sbomify.com/CVE-2020-5275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5275
- OSV: https://osv.dev/vulnerability/CVE-2020-5275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5275/
Summaries are generated and may contain mistakes; the official description above is the record.
