# CVE-2020-5277: Reflected XSS with url_name parameter of PrestaShop module ps_facetedsearch

> Attackers can execute arbitrary scripts in victim browsers via the url_name parameter in the PrestaShop ps_facetedsearch module.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mmmv-m5q9-g3cm

## What is CVE-2020-5277?

CVE-2020-5277 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_facetedsearch, published on 25 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PrestaShop module ps_facetedsearch versions before 3.5.0 has a reflected XSS with `url_name` parameter. The problem is fixed in 3.5.0

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-5277?

It affects 1 product.


Products: Prestashop Faceted Search Module.

## How do I fix CVE-2020-5277?

No fix has been published for CVE-2020-5277 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-5277 being exploited?

There is no known exploitation of CVE-2020-5277 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5277 and fix it if it is affected.

What it is: CVE-2020-5277 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_facetedsearch, published on 25 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5277 in the wild and no public exploit code.

Affected product: PrestaShop ps_facetedsearch. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5277/ (Markdown: https://insights.sbomify.com/CVE-2020-5277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5277
- OSV: https://osv.dev/vulnerability/CVE-2020-5277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5277/
Summaries are generated and may contain mistakes; the official description above is the record.
