# CVE-2020-5282: arbitrary shell execution in Nick Chan Bot

> Attackers can execute arbitrary shell commands via the npm command in Nick Chan Bot, compromising the bot's security.

- **Severity:** High 7.2 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Mar 2020
- **Updated:** 4 Aug 2024

## What is CVE-2020-5282?

CVE-2020-5282 is a high-severity command injection vulnerability in nickchanbot, published on 25 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Nick Chan Bot before version 1.0.0-beta there is a vulnerability in the `npm` command which is part of this software package. This allows arbitrary shell execution,which can compromise the bot This is patched in version 1.0.0-beta

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-5282?

It affects 1 product.


Products: Nick Chan Bot Project Nick Chan Bot.

## How do I fix CVE-2020-5282?

No fix has been published for CVE-2020-5282 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-5282 being exploited?

There is no known exploitation of CVE-2020-5282 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5282 and fix it if it is affected.

What it is: CVE-2020-5282 is a high-severity command injection vulnerability in nickchanbot, published on 25 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5282 in the wild and no public exploit code.

Affected product: nickchanbot. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5282/ (Markdown: https://insights.sbomify.com/CVE-2020-5282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5282
- OSV: https://osv.dev/vulnerability/CVE-2020-5282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5282/
Summaries are generated and may contain mistakes; the official description above is the record.
