CVE-2020-5283 XSS vulnerability in CVS show_subdir_lastmod support
Attackers with commit privileges can inject malicious scripts via unsafe filenames in ViewVC when the show_subdir_lastmod feature is enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-5283?
CVE-2020-5283 is a low-severity cross-site scripting vulnerability in viewvc, published on 3 Apr 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
ViewVC before versions 1.1.28 and 1.2.1 has a XSS vulnerability in CVS show_subdir_lastmod support. The impact of this vulnerability is mitigated by the need for an attacker to have commit privileges to a CVS repository exposed by an otherwise trusted ViewVC instance that also has the `show_subdir_lastmod` feature enabled. The attack vector involves files with unsafe names (names that, when embedded into an HTML stream, would cause the browser to run unwanted code), which themselves can be challenging to create. This vulnerability is patched in versions 1.2.1 and 1.1.28.
Which versions are affected by CVE-2020-5283?
It affects 1 product.
Linux distribution packages (4)
viewvc SUSE:Package Hub 15 SP1 | All versions | 1.1.28-bp151.4.3.1 |
viewvc SUSE:Package Hub 15 SP2 | All versions | 1.1.28-bp152.4.3.1 |
viewvc openSUSE:Leap 15.1 | All versions | 1.1.28-lp151.3.3.1 |
viewvc openSUSE:Leap 15.2 | All versions | 1.1.28-lp152.4.3.1 |
Products include Viewvc Viewvc.
How do I fix CVE-2020-5283?
Upgrade to a fixed version.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-5283 being exploited?
There is no known exploitation of CVE-2020-5283 in the wild and no public exploit code.
Other vulnerabilities in viewvc
Sources
Also known as GHSA-xpxf-fvqv-7mfg, MGASA-2020-0221, UBUNTU-CVE-2020-5283, openSUSE-SU-2021:0084-1, openSUSE-SU-2021:0119-1, openSUSE-SU-2021:0123-1 and 1 more.