# CVE-2020-5289: Read permissions not enforced for client provided filter expressions in Elide http client

> Attackers can infer values of inaccessible model fields by observing filter results, leading to unauthorized data disclosure in Elide applications.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2mxr-89gf-rc4v

## What is CVE-2020-5289?

CVE-2020-5289 is a medium-severity missing authorization vulnerability in yahoo elide, published on 30 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Elide before 4.5.14, it is possible for an adversary to "guess and check" the value of a model field they do not have access to assuming they can read at least one other field in the model. The adversary can construct filter expressions for an inaccessible field to filter a collection. The presence or absence of models in the returned collection can be used to reconstruct the value of the inaccessible field. Resolved in Elide 4.5.14 and greater.

Weakness: CWE-552 (Files or Directories Accessible to External Parties), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-5289?

2 open source packages ship an affected version, including com.yahoo.elide:elide-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.yahoo.elide:elide-core` | Maven | All versions | 4.5.14 |
| `com.yahoo.elide:elide-core` | Maven | All versions | 4.5.14 |

Products: Elide Elide.

## How do I fix CVE-2020-5289?

Upgrade com.yahoo.elide:elide-core to 4.5.14 or later.

## Is CVE-2020-5289 being exploited?

There is no known exploitation of CVE-2020-5289 in the wild and no public exploit code.

## Other vulnerabilities in yahoo elide

- [CVE-2022-24827](https://insights.sbomify.com/CVE-2022-24827/): SQL Injection in elide-datastore-aggregation (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5289 and fix it if it is affected.

What it is: CVE-2020-5289 is a medium-severity missing authorization vulnerability in yahoo elide, published on 30 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5289 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.yahoo.elide:elide-core (Maven): affected all versions; fixed in 4.5.14
- com.yahoo.elide:elide-core (Maven): affected all versions; fixed in 4.5.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5289/ (Markdown: https://insights.sbomify.com/CVE-2020-5289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5289
- OSV: https://osv.dev/vulnerability/CVE-2020-5289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5289/
Summaries are generated and may contain mistakes; the official description above is the record.
