{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-5291 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-5291 is a high-severity vulnerability in Debian Debian Linux, published on 31 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-5291 and fix it if it is affected.\n\nWhat it is: CVE-2020-5291 is a high-severity vulnerability in Debian Debian Linux, published on 31 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-5291 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-5291/ (Markdown: https://insights.sbomify.com/CVE-2020-5291/index.md)","id":"CVE-2020-5291","markdown":"https://insights.sbomify.com/CVE-2020-5291/index.md","name":"CVE-2020-5291","record":{"aliases":["ALPINE-CVE-2020-5291","DEBIAN-CVE-2020-5291","GHSA-j2qp-rvxj-43vj","UBUNTU-CVE-2020-5291"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Linux sandbox tool","requires_auth":"low_privilege","summary":"Attackers can gain root privileges in Bubblewrap when setuid mode and unprivileged user namespaces are enabled.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"arch_linux","vendor":"archlinux"},{"product":"centos","vendor":"centos"},{"product":"debian_linux","vendor":"debian"},{"product":"bubblewrap","vendor":"projectatomic"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-648","name":"Incorrect Use of Privileged APIs"}],"description":"Bubblewrap (bwrap) before version 0.4.1, if installed in setuid mode and the kernel supports unprivileged user namespaces, then the `bwrap --userns2` option can be used to make the setuid process keep running as root while being traceable. This can in turn be used to gain root permissions. Note that this only affects the combination of bubblewrap in setuid mode (which is typically used when unprivileged user namespaces are not supported) and the support of unprivileged user namespaces. Known to be affected are: * Debian testing/unstable, if unprivileged user namespaces enabled (not default) * Debian buster-backports, if unprivileged user namespaces enabled (not default) * Arch if using `linux-hardened`, if unprivileged user namespaces enabled (not default) * Centos 7 flatpak COPR, if unprivileged user namespaces enabled (not default) This has been fixed in the 0.4.1 release, and all affected users should update.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in setuid mode via user namespaces in Bubblewrap","id":"CVE-2020-5291","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"privilege_escalation","year":"2020"},"n_packages":0,"n_references":2,"next":{"headline":"Time-based blind injection in Leantime","id":"CVE-2020-5292"},"packages":[],"prev":{"headline":"session fixation in rCTF","id":"CVE-2020-5290"},"products":["bubblewrap"],"published":"2020-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["containers"]},"summary":"Attackers can gain root privileges in Bubblewrap when setuid mode and unprivileged user namespaces are enabled.","url":"https://insights.sbomify.com/CVE-2020-5291/"}