# CVE-2020-5294: Reflected XSS with social networks fields

> Attackers can execute arbitrary scripts in victim browsers via reflected XSS in social network fields, requiring module upgrade.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-774w-fg8p-7c8w

## What is CVE-2020-5294?

CVE-2020-5294 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_socialfollow, published on 16 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PrestaShop module ps_facetedsearch versions before 2.1.0 has a reflected XSS with social networks fields The problem is fixed in 2.1.0

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-5294?

It affects 1 product.


Products: Prestashop Prestashop Socialfollow.

## How do I fix CVE-2020-5294?

No fix has been published for CVE-2020-5294 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-5294 being exploited?

There is no known exploitation of CVE-2020-5294 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5294 and fix it if it is affected.

What it is: CVE-2020-5294 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_socialfollow, published on 16 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5294 in the wild and no public exploit code.

Affected product: PrestaShop ps_socialfollow. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5294/ (Markdown: https://insights.sbomify.com/CVE-2020-5294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5294
- OSV: https://osv.dev/vulnerability/CVE-2020-5294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5294/
Summaries are generated and may contain mistakes; the official description above is the record.
