# CVE-2020-5390: Improper Verification of Cryptographic Signature in PySAML2

> Attackers can bypass SAML signature verification via XML Signature Wrapping, allowing them to forge authenticated assertions in applications using PySAML2.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-5390, DLA-2119-1, DSA-4630-1, GHSA-qf7v-8hj3-4xw7, PYSEC-2020-94, UBUNTU-CVE-2020-5390, USN-4245-1

## What is CVE-2020-5390?

CVE-2020-5390 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 13 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PySAML2 before 5.0.0 does not check that the signature in a SAML document is enveloped and thus signature wrapping is effective, i.e., it is affected by XML Signature Wrapping (XSW). The signature information and the node/object that is signed can be in different places and thus the signature verification will succeed, but the wrong data will be used. This specifically affects the verification of assertion that have been signed.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2020-5390?

3 open source packages ship an affected version, including pysaml2. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pysaml2` | PyPI | All versions | 5.0.0 |
| `pysaml2` | PyPI | All versions | 5.0.0 |
| `pysaml2` | PyPI | All versions | 5.0.0 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Pysaml2 Project Pysaml2.

## How do I fix CVE-2020-5390?

Upgrade pysaml2 to 5.0.0 or later.

## Is CVE-2020-5390 being exploited?

There is no known exploitation of CVE-2020-5390 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5390 and fix it if it is affected.

What it is: CVE-2020-5390 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 13 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-5390 in the wild and no public exploit code.

Affected packages and fixed versions:
- pysaml2 (PyPI): affected all versions; fixed in 5.0.0
- pysaml2 (PyPI): affected all versions; fixed in 5.0.0
- pysaml2 (PyPI): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5390/ (Markdown: https://insights.sbomify.com/CVE-2020-5390/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5390
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5390
- OSV: https://osv.dev/vulnerability/CVE-2020-5390

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5390/
Summaries are generated and may contain mistakes; the official description above is the record.
