# CVE-2020-5404: Authentication Leak On Redirect With Reactor Netty HttpClient

> Attackers can steal credentials when a configured HTTP client follows redirects to a different domain.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Mar 2020
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-gpch-h32j-gx6x

## What is CVE-2020-5404?

CVE-2020-5404 is a medium-severity vulnerability in Pivotal Reactor Netty, published on 3 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The HttpClient from Reactor Netty, versions 0.9.x prior to 0.9.5, and versions 0.8.x prior to 0.8.16, may be used incorrectly, leading to a credentials leak during a redirect to a different domain. In order for this to happen, the HttpClient must have been explicitly configured to follow redirects.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2020-5404?

4 open source packages ship an affected version, including io.projectreactor.netty:reactor-netty-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.projectreactor.netty:reactor-netty-http` | Maven | From 0.8.0 | 0.8.16 |
| `io.projectreactor.netty:reactor-netty-http` | Maven | From 0.8.0 | 0.8.16 |
| `io.projectreactor.netty:reactor-netty-http` | Maven | From 0.9.0 | 0.9.5 |
| `io.projectreactor.netty:reactor-netty-http` | Maven | From 0.9.0 | 0.9.5 |

Products: Broadcom Reactor Netty.

## How do I fix CVE-2020-5404?

Upgrade io.projectreactor.netty:reactor-netty-http to a fixed version for your release line: 0.8.16 or 0.9.5.

## Is CVE-2020-5404 being exploited?

There is no known exploitation of CVE-2020-5404 in the wild and no public exploit code.

## Other vulnerabilities in Pivotal Reactor Netty

- [CVE-2023-34062](https://insights.sbomify.com/CVE-2023-34062/): In Reactor Netty HTTP Server a malicious user can send a request using a specially crafted URL that can lead to a directory traversal attack (high 7.5)
- [CVE-2019-11284](https://insights.sbomify.com/CVE-2019-11284/): Reactor Netty authentication leak in redirects (medium 6.8)
- [CVE-2020-5403](https://insights.sbomify.com/CVE-2020-5403/): DoS Via Malformed URL with Reactor Netty HTTP Server (medium 6.5)
- [CVE-2026-47848](https://insights.sbomify.com/CVE-2026-47848/): Reactor Netty WebSocket Client Leaks Credentials On Redirect (medium 6.1)
- [CVE-2026-47844](https://insights.sbomify.com/CVE-2026-47844/): Reactor Netty HTTP Server Leaks Exception Details (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5404 and fix it if it is affected.

What it is: CVE-2020-5404 is a medium-severity vulnerability in Pivotal Reactor Netty, published on 3 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5404 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.projectreactor.netty:reactor-netty-http (Maven): affected from 0.8.0; fixed in 0.8.16
- io.projectreactor.netty:reactor-netty-http (Maven): affected from 0.8.0; fixed in 0.8.16
- io.projectreactor.netty:reactor-netty-http (Maven): affected from 0.9.0; fixed in 0.9.5
- io.projectreactor.netty:reactor-netty-http (Maven): affected from 0.9.0; fixed in 0.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5404/ (Markdown: https://insights.sbomify.com/CVE-2020-5404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5404
- OSV: https://osv.dev/vulnerability/CVE-2020-5404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5404/
Summaries are generated and may contain mistakes; the official description above is the record.
