# CVE-2020-5408: Dictionary attack with Spring Security queryable text encryptor

> An attacker with access to encrypted data can derive plaintext values via dictionary attack due to fixed initialization vectors in Spring Security's queryable text encryptor.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2020
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-2ppp-9496-p23q

## What is CVE-2020-5408?

CVE-2020-5408 is a medium-severity vulnerability in Spring Security, published on 14 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spring Security versions 5.3.x prior to 5.3.2, 5.2.x prior to 5.2.4, 5.1.x prior to 5.1.10, 5.0.x prior to 5.0.16 and 4.2.x prior to 4.2.16 use a fixed null initialization vector with CBC Mode in the implementation of the queryable text encryptor. A malicious user with access to the data that has been encrypted using such an encryptor may be able to derive the unencrypted values using a dictionary attack.

Weakness: CWE-330 (Use of Insufficiently Random Values), CWE-329 (Generation of Predictable IV with CBC Mode)

## Which versions are affected by CVE-2020-5408?

10 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | All versions | 4.2.16 |
| `org.springframework.security:spring-security-core` | Maven | All versions | 4.2.16 |
| `org.springframework.security:spring-security-core` | Maven | From 5.0.0 | 5.0.16 |
| `org.springframework.security:spring-security-core` | Maven | From 5.0.0 | 5.0.16 |
| `org.springframework.security:spring-security-core` | Maven | From 5.1.0 | 5.1.10 |
| `org.springframework.security:spring-security-core` | Maven | From 5.1.0 | 5.1.10 |
| `org.springframework.security:spring-security-core` | Maven | From 5.2.0 | 5.2.4 |
| `org.springframework.security:spring-security-core` | Maven | From 5.2.0 | 5.2.4 |
| `org.springframework.security:spring-security-core` | Maven | From 5.3.0 | 5.3.2 |
| `org.springframework.security:spring-security-core` | Maven | From 5.3.0 | 5.3.2 |

Products: Pivotal Software Spring Security, Vmware Spring Security.

## How do I fix CVE-2020-5408?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 4.2.16, 5.0.16, 5.1.10 or 5.2.4.

## Is CVE-2020-5408 being exploited?

There is no known exploitation of CVE-2020-5408 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2020-5407](https://insights.sbomify.com/CVE-2020-5407/): Signature Wrapping Vulnerability with spring-security-saml2-service-provider (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5408 and fix it if it is affected.

What it is: CVE-2020-5408 is a medium-severity vulnerability in Spring Security, published on 14 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-5408 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 4.2.16
- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 4.2.16
- org.springframework.security:spring-security-core (Maven): affected from 5.0.0; fixed in 5.0.16
- org.springframework.security:spring-security-core (Maven): affected from 5.0.0; fixed in 5.0.16
- org.springframework.security:spring-security-core (Maven): affected from 5.1.0; fixed in 5.1.10
- org.springframework.security:spring-security-core (Maven): affected from 5.1.0; fixed in 5.1.10
- org.springframework.security:spring-security-core (Maven): affected from 5.2.0; fixed in 5.2.4
- org.springframework.security:spring-security-core (Maven): affected from 5.2.0; fixed in 5.2.4
- org.springframework.security:spring-security-core (Maven): affected from 5.3.0; fixed in 5.3.2
- org.springframework.security:spring-security-core (Maven): affected from 5.3.0; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5408/ (Markdown: https://insights.sbomify.com/CVE-2020-5408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5408
- OSV: https://osv.dev/vulnerability/CVE-2020-5408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5408/
Summaries are generated and may contain mistakes; the official description above is the record.
