# CVE-2020-5410: VMware Tanzu Spring Cloud Config Directory Traversal

> Attackers can read arbitrary configuration files from the server via crafted URLs in Spring Cloud Config Server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Yes, since 25 Mar 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2020
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-32xf-jwmv-9hf3

## What is CVE-2020-5410?

CVE-2020-5410 is a high-severity path traversal vulnerability in Spring Cloud Config, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Cloud Config, versions 2.2.x prior to 2.2.3, versions 2.1.x prior to 2.1.9, and older unsupported versions allow applications to serve arbitrary configuration files through the spring-cloud-config-server module. A malicious user, or attacker, can send a request using a specially crafted URL that can lead to a directory traversal attack.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2020-5410?

4 open source packages ship an affected version, including org.springframework.cloud:spring-cloud-config-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 2.1.0 | 2.1.9 |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 2.1.0 | 2.1.9 |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 2.2.0 | 2.2.3 |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 2.2.0 | 2.2.3 |

Products: Vmware Spring Cloud Config.

## How do I fix CVE-2020-5410?

Upgrade org.springframework.cloud:spring-cloud-config-server to a fixed version for your release line: 2.1.9 or 2.2.3. US federal agencies must fix it by 15 Apr 2022.

## Is CVE-2020-5410 being exploited?

Yes. Attackers have exploited CVE-2020-5410 in the wild since at least 25 Mar 2022.

Public exploit code:

- Directory Traversal in Spring Cloud Config Server (metasploit)
- CVE-2020-5410 (github_poc): https://github.com/dead5nd/config-demo
- https://github.com/shoucheng3/spring-cloud__spring-cloud-config_CVE-2020-5410_2-1-8-RELEASE (github_poc): https://github.com/shoucheng3/spring-cloud__spring-cloud-config_CVE-2020-5410_2-1-8-RELEASE
- Spring Cloud Config Server - Local File Inclusion (nuclei): http/cves/2020/CVE-2020-5410.yaml

## Other vulnerabilities in Spring Cloud Config

- [CVE-2026-40982](https://insights.sbomify.com/CVE-2026-40982/): Spring Cloud Config vulnerable to Path Traversal (critical 9.1)
- [CVE-2026-22739](https://insights.sbomify.com/CVE-2026-22739/): Spring Cloud Config Profile Substitution Can Allow Unintended Access To Files And Enable SSRF Attacks (high 8.6)
- [CVE-2026-40981](https://insights.sbomify.com/CVE-2026-40981/): Spring Cloud Config has an Authorization Bypass Through User-Controlled Key (high 7.5)
- [CVE-2026-41002](https://insights.sbomify.com/CVE-2026-41002/): Spring Cloud Config Server Susceptible To TOCTOU Attack (high 7.4)
- [CVE-2026-47836](https://insights.sbomify.com/CVE-2026-47836/): Spring Cloud Config Server Susceptible To TOCTOU Attack When Using SVN (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5410 and fix it if it is affected.

What it is: CVE-2020-5410 is a high-severity path traversal vulnerability in Spring Cloud Config, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2020-5410 in the wild since at least 25 Mar 2022.

Affected packages and fixed versions:
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 2.1.0; fixed in 2.1.9
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 2.1.0; fixed in 2.1.9
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 2.2.0; fixed in 2.2.3
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 2.2.0; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5410/ (Markdown: https://insights.sbomify.com/CVE-2020-5410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5410
- OSV: https://osv.dev/vulnerability/CVE-2020-5410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5410/
Summaries are generated and may contain mistakes; the official description above is the record.
