# CVE-2020-5504: phpMyAdmin SQL injection in user accounts page

> Authenticated users can inject SQL via username fields in phpMyAdmin, allowing unauthorized database access or modification.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2020
- **Updated:** 16 Apr 2025
- **Also known as:** BIT-phpmyadmin-2020-5504, DEBIAN-CVE-2020-5504, DLA-2060-1, GHSA-fgj8-93xx-f6g6, MGASA-2020-0033, UBUNTU-CVE-2020-5504

## What is CVE-2020-5504?

CVE-2020-5504 is a high-severity SQL injection vulnerability in Debian Debian Linux, published on 9 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-5504?

5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0.0 | 4.9.4 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0.0 | 4.9.4 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.0.1 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.0.1 |
| `phpmyadmin` | Bitnami | From 4.0.0 | 4.9.4, 5.0.1 |

Products: Debian Debian Linux, Phpmyadmin Phpmyadmin, Suse Suse Linux Enterprise Server.

## How do I fix CVE-2020-5504?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.4 or 5.0.1.

## Is CVE-2020-5504 being exploited?

There is no known exploitation of CVE-2020-5504 in the wild and no public exploit code.

Public exploit code:

- https://github.com/xMohamed0/CVE-2020-5504-phpMyAdmin (github_poc): https://github.com/xMohamed0/CVE-2020-5504-phpMyAdmin
- phpMyAdmin 5.0.0 - SQL Injection (exploitdb)
- Professional PHPMyAdmin 5.0.0 SQL Injection (CVE-2020-5504) exploitation framework with automated database enumeration, table extraction, and data dumping capabilities. Features blind injection, proxy support, JSON output, and comprehensive error handling for authorized penetration testing and security research.  Author: Sudeepa Wanigarathna (github_poc): https://github.com/CerberusMrXi/phpMyAdmin-CVE-2020-5504-Exploit

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5504 and fix it if it is affected.

What it is: CVE-2020-5504 is a high-severity SQL injection vulnerability in Debian Debian Linux, published on 9 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-5504 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.0; fixed in 4.9.4
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.0; fixed in 4.9.4
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.1
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.1
- phpmyadmin (Bitnami): affected from 4.0.0; fixed in 4.9.4, 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5504/ (Markdown: https://insights.sbomify.com/CVE-2020-5504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5504
- OSV: https://osv.dev/vulnerability/CVE-2020-5504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5504/
Summaries are generated and may contain mistakes; the official description above is the record.
