# CVE-2020-6165: Silverstripe has Incorrect Default Permissions

> Authenticated users can read unauthorized records via GraphQL endpoints due to flawed permission checks in SilverStripe CMS.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-silverstripe-2020-6165, GHSA-589q-75r3-mfq4

## What is CVE-2020-6165?

CVE-2020-6165 is a medium-severity missing authorization vulnerability in Silverstripe Silverstripe, published on 15 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SilverStripe 4.5.0 allows attackers to read certain records that should not have been placed into a result set. This affects silverstripe/recipe-cms. The automatic permission-checking mechanism in the silverstripe/graphql module does not provide complete protection against lists that are limited (e.g., through pagination), resulting in records that should have failed a permission check being added to the final result set. GraphQL endpoints are configured by default (e.g., for assets), but the admin/graphql endpoint is access protected by default. This limits the vulnerability to all authenticated users, including those with limited permissions (e.g., where viewing records exposed through admin/graphql requires administrator permissions). However, if custom GraphQL endpoints have been configured for a specific implementation (usually under /graphql), this vulnerability could also be exploited through unauthenticated requests. This vulnerability only applies to reading records; it does not allow unauthorised changing of records.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2020-6165?

5 open source packages ship an affected version, including silverstripe/graphql, silverstripe and silverstripe/recipe-cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/graphql` | Packagist | From 3.2.0 | 3.2.4 |
| `silverstripe/graphql` | Packagist | From 3.2.0 | 3.2.4 |
| `silverstripe` | Bitnami | From 3.2.0 | 3.2.4, 3.3.0, 4.5.3 |
| `silverstripe/recipe-cms` | Packagist | From 4.5.0 | 4.5.3 |
| `silverstripe/recipe-cms` | Packagist | From 4.5.0 | 4.5.3 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2020-6165?

Upgrade silverstripe/graphql to 3.2.4 or later.

## Is CVE-2020-6165 being exploited?

There is no known exploitation of CVE-2020-6165 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-6165 and fix it if it is affected.

What it is: CVE-2020-6165 is a medium-severity missing authorization vulnerability in Silverstripe Silverstripe, published on 15 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-6165 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/graphql (Packagist): affected from 3.2.0; fixed in 3.2.4
- silverstripe/graphql (Packagist): affected from 3.2.0; fixed in 3.2.4
- silverstripe (Bitnami): affected from 3.2.0; fixed in 3.2.4, 3.3.0, 4.5.3
- silverstripe/recipe-cms (Packagist): affected from 4.5.0; fixed in 4.5.3
- silverstripe/recipe-cms (Packagist): affected from 4.5.0; fixed in 4.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-6165/ (Markdown: https://insights.sbomify.com/CVE-2020-6165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-6165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-6165
- OSV: https://osv.dev/vulnerability/CVE-2020-6165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-6165/
Summaries are generated and may contain mistakes; the official description above is the record.
