CVE-2020-6173 Client Denial of Service on TUF
Medium 5.3
Published
Updated
Check this codebase for CVE-2020-6173 and fix it if it is affected.
What it is: CVE-2020-6173 is a medium-severity vulnerability in n/a, published on 14 Jan 2020.
Exploitation: There is no known exploitation of CVE-2020-6173 in the wild and no public exploit code.
Affected packages and fixed versions:
- tuf (PyPI): affected from 0.7.2; fixed in 0.12.2
- tuf (PyPI): affected from 0.7.2; fixed in 0.12.2
- tuf (PyPI): affected from 0.7.5; fixed in 0.12.2
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2020-6173/ (Markdown: https://insights.sbomify.com/CVE-2020-6173/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2020-6173?
CVE-2020-6173 is a medium-severity vulnerability in n/a, published on 14 Jan 2020.
Official description
TUF (aka The Update Framework) 0.7.2 through 0.12.1 allows Uncontrolled Resource Consumption.
Weakness: CWE-400
Which versions are affected by CVE-2020-6173?
3 open source packages ship an affected version, including tuf. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tuf PyPI | From 0.7.2 | 0.12.2 |
tuf PyPI | From 0.7.2 | 0.12.2 |
tuf PyPI | From 0.7.5 | 0.12.2 |
Products include Linuxfoundation the Update Framework.
How do I fix CVE-2020-6173?
Upgrade tuf to 0.12.2 or later.
Is CVE-2020-6173 being exploited?
There is no known exploitation of CVE-2020-6173 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-2828-9vh6-9m6j, PYSEC-2020-146.