# CVE-2020-6174: Incorrect threshold signature computation in TUF

> Attackers can bypass cryptographic signature verification in the TUF library, potentially allowing the installation of malicious software updates.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-pwqf-9h7j-7mv8, PYSEC-2020-147

## What is CVE-2020-6174?

CVE-2020-6174 is a critical vulnerability in n/a, published on 5 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TUF (aka The Update Framework) through 0.12.1 has Improper Verification of a Cryptographic Signature.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2020-6174?

3 open source packages ship an affected version, including tuf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tuf` | PyPI | All versions | 0.12.2 |
| `tuf` | PyPI | All versions | 0.12.2 |
| `tuf` | PyPI | All versions | 0.12.2 |

Products: Linuxfoundation the Update Framework.

## How do I fix CVE-2020-6174?

Upgrade tuf to 0.12.2 or later.

## Is CVE-2020-6174 being exploited?

There is no known exploitation of CVE-2020-6174 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15163](https://insights.sbomify.com/CVE-2020-15163/): Invalid root may become trusted root in The Update Framework (TUF) (high 8.7)
- [CVE-2021-41131](https://insights.sbomify.com/CVE-2021-41131/): Client metadata path-traversal in python-tuf (high 7.5)
- [CVE-2020-6173](https://insights.sbomify.com/CVE-2020-6173/): Client Denial of Service on TUF (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-6174 and fix it if it is affected.

What it is: CVE-2020-6174 is a critical vulnerability in n/a, published on 5 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-6174 in the wild and no public exploit code.

Affected packages and fixed versions:
- tuf (PyPI): affected all versions; fixed in 0.12.2
- tuf (PyPI): affected all versions; fixed in 0.12.2
- tuf (PyPI): affected all versions; fixed in 0.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-6174/ (Markdown: https://insights.sbomify.com/CVE-2020-6174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-6174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-6174
- OSV: https://osv.dev/vulnerability/CVE-2020-6174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-6174/
Summaries are generated and may contain mistakes; the official description above is the record.
