{"answers":{"affected":"2 open source packages ship an affected version, including zencart/zencart. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-6578 in the wild and no public exploit code.","fix":"Upgrade zencart/zencart to 1.5.7a or later.","what":"CVE-2020-6578 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-6578 and fix it if it is affected.\n\nWhat it is: CVE-2020-6578 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-6578 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zencart/zencart (Packagist): affected all versions; fixed in 1.5.7a\n- zencart/zencart (Packagist): affected all versions; fixed in 1.5.7a\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-6578/ (Markdown: https://insights.sbomify.com/CVE-2020-6578/index.md)","id":"CVE-2020-6578","markdown":"https://insights.sbomify.com/CVE-2020-6578/index.md","name":"CVE-2020-6578","record":{"aliases":["GHSA-wxxx-2x6v-979f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Zen Cart e-commerce","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers via reflected XSS in Zen Cart, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"zen_cart","vendor":"zen-cart"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Zen Cart 1.5.6d allows reflected XSS via the main_page parameter to includes/templates/template_default/common/tpl_main_page.php or includes/templates/responsive_classic/common/tpl_main_page.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected XSS in Zen Cart before 1.5.7a","id":"CVE-2020-6578","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-6579"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.7a"],"introduced":["0"],"last_affected":[],"package":"zencart/zencart","purl":null,"source":"GHSA-wxxx-2x6v-979f"},{"ecosystem":"Packagist","fixed":["1.5.7a"],"introduced":["0"],"last_affected":[],"package":"zencart/zencart","purl":"pkg:composer/zencart/zencart","source":"GHSA-wxxx-2x6v-979f"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2020-6577"},"products":["n/a"],"published":"2021-03-19","related":[{"cvss_score":10,"headline":"Missing authorization in n/a","id":"CVE-2006-0697","kev_date_added":null,"published":"2006-02-15"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2015-8352","kev_date_added":null,"published":"2017-08-24"},{"cvss_score":8.8,"headline":"Authenticated RCE in Zen Cart 1.5.5e","id":"CVE-2017-11675","kev_date_added":null,"published":"2017-07-27"},{"cvss_score":8.1,"headline":"Zen Cart findPluginAdminPage Local File Inclusion Remote Code Execution Vulnerability","id":"CVE-2024-5762","kev_date_added":null,"published":"2024-08-21"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2009-4323","kev_date_added":null,"published":"2009-12-14"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2009-2254","kev_date_added":null,"published":"2009-06-30"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2008-6615","kev_date_added":null,"published":"2009-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts in victim browsers via reflected XSS in Zen Cart, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2020-6578/"}