CVE-2020-6638 Grin Insufficient Validation
High 7.5
Published
Updated
Check this codebase for CVE-2020-6638 and fix it if it is affected.
What it is: CVE-2020-6638 is a high-severity vulnerability in n/a, published on 21 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-6638 in the wild and no public exploit code.
Affected packages and fixed versions:
- grin (crates.io): affected all versions; fixed in 3.0.0
- grin (crates.io): affected all versions; fixed in 3.0.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2020-6638/ (Markdown: https://insights.sbomify.com/CVE-2020-6638/index.md)
Insufficient validation in Grin allows attackers to potentially disrupt node operations or cause unexpected behavior.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-6638?
CVE-2020-6638 is a high-severity vulnerability in n/a, published on 21 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Grin through 2.1.1 has Insufficient Validation.
Weakness: CWE-20
Which versions are affected by CVE-2020-6638?
2 open source packages ship an affected version, including grin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
grin crates.io | All versions | 3.0.0 |
grin crates.io | All versions | 3.0.0 |
Products include Grin Grin.
How do I fix CVE-2020-6638?
Upgrade grin to 3.0.0 or later.
Is CVE-2020-6638 being exploited?
There is no known exploitation of CVE-2020-6638 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-7w6p-rwhg-7h3g.