{"answers":{"affected":"5 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-7009 in the wild and no public exploit code.","fix":"Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.8 or 7.6.2.","what":"CVE-2020-7009 is a high-severity vulnerability in Elastic Elasticsearch, published on 31 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7009 and fix it if it is affected.\n\nWhat it is: CVE-2020-7009 is a high-severity vulnerability in Elastic Elasticsearch, published on 31 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7009 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.elasticsearch:elasticsearch (Maven): affected from 6.7.0; fixed in 6.8.8\n- org.elasticsearch:elasticsearch (Maven): affected from 6.7.0; fixed in 6.8.8\n- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.6.2\n- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.6.2\n- elasticsearch (Bitnami): affected from 6.7.0; fixed in 6.8.8, 7.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7009/ (Markdown: https://insights.sbomify.com/CVE-2020-7009/index.md)","id":"CVE-2020-7009","markdown":"https://insights.sbomify.com/CVE-2020-7009/index.md","name":"CVE-2020-7009","record":{"aliases":["BIT-elasticsearch-2020-7009","GHSA-gfv5-grx2-9jw2","UBUNTU-CVE-2020-7009"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Elasticsearch search engine","requires_auth":"low_privilege","summary":"Attackers with API key creation rights can escalate privileges in Elasticsearch, requiring upgrades to secure the search engine.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"elasticsearch","vendor":"elastic"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Privilege Management in Elasticsearch","id":"CVE-2020-7009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"elastic:elasticsearch","products":["elastic:elasticsearch"],"type":"privilege_escalation","year":"2020"},"n_packages":5,"n_references":3,"next":{"headline":"Cryptographic Issues in ECK","id":"CVE-2020-7010"},"packages":[{"ecosystem":"Bitnami","fixed":["6.8.8","7.6.2"],"introduced":["6.7.0","7.0.0"],"last_affected":[],"package":"elasticsearch","purl":"pkg:bitnami/elasticsearch","source":"BIT-elasticsearch-2020-7009"},{"ecosystem":"Maven","fixed":["6.8.8"],"introduced":["6.7.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":null,"source":"GHSA-gfv5-grx2-9jw2"},{"ecosystem":"Maven","fixed":["6.8.8"],"introduced":["6.7.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","source":"GHSA-gfv5-grx2-9jw2"},{"ecosystem":"Maven","fixed":["7.6.2"],"introduced":["7.0.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":null,"source":"GHSA-gfv5-grx2-9jw2"},{"ecosystem":"Maven","fixed":["7.6.2"],"introduced":["7.0.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","source":"GHSA-gfv5-grx2-9jw2"}],"prev":{"headline":"Path traversal in VBASE Editor","id":"CVE-2020-7008"},"products":["Elasticsearch"],"published":"2020-03-31","related":[{"cvss_score":9.8,"headline":"Elasticsearch Groovy Scripting Engine Remote Code Execution","id":"CVE-2015-1427","kev_date_added":"2022-03-25","published":"2015-02-17"},{"cvss_score":8.1,"headline":"Elasticsearch Remote Code Execution","id":"CVE-2014-3120","kev_date_added":"2022-03-25","published":"2014-07-28"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2015-5377","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":8.8,"headline":"Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution","id":"CVE-2026-72649","kev_date_added":null,"published":"2026-09-01"},{"cvss_score":8.8,"headline":"Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process","id":"CVE-2026-72642","kev_date_added":null,"published":"2026-08-13"},{"cvss_score":8.8,"headline":"Privilege Escalation Flaw in Elasticsearch","id":"CVE-2020-7014","kev_date_added":null,"published":"2020-06-03"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Elastic"]},"summary":"Attackers with API key creation rights can escalate privileges in Elasticsearch, requiring upgrades to secure the search engine.","url":"https://insights.sbomify.com/CVE-2020-7009/"}