# CVE-2020-7009: Improper Privilege Management in Elasticsearch

> Attackers with API key creation rights can escalate privileges in Elasticsearch, requiring upgrades to secure the search engine.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-elasticsearch-2020-7009, GHSA-gfv5-grx2-9jw2, UBUNTU-CVE-2020-7009

## What is CVE-2020-7009?

CVE-2020-7009 is a high-severity vulnerability in Elastic Elasticsearch, published on 31 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Weakness: CWE-269 (Improper Privilege Management), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2020-7009?

5 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 6.7.0 | 6.8.8 |
| `org.elasticsearch:elasticsearch` | Maven | From 6.7.0 | 6.8.8 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.0.0 | 7.6.2 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.0.0 | 7.6.2 |
| `elasticsearch` | Bitnami | From 6.7.0 | 6.8.8, 7.6.2 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2020-7009?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.8 or 7.6.2.

## Is CVE-2020-7009 being exploited?

There is no known exploitation of CVE-2020-7009 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7009 and fix it if it is affected.

What it is: CVE-2020-7009 is a high-severity vulnerability in Elastic Elasticsearch, published on 31 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7009 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 6.7.0; fixed in 6.8.8
- org.elasticsearch:elasticsearch (Maven): affected from 6.7.0; fixed in 6.8.8
- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.6.2
- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.6.2
- elasticsearch (Bitnami): affected from 6.7.0; fixed in 6.8.8, 7.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7009/ (Markdown: https://insights.sbomify.com/CVE-2020-7009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7009
- OSV: https://osv.dev/vulnerability/CVE-2020-7009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7009/
Summaries are generated and may contain mistakes; the official description above is the record.
