# CVE-2020-7020: Privilege Context Switching Error in Elasticsearch

> Attackers can view existence of restricted documents in Elasticsearch when using Document or Field Level Security features.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-elasticsearch-2020-7020, GHSA-g9fw-9x87-rmrj, UBUNTU-CVE-2020-7020

## What is CVE-2020-7020?

CVE-2020-7020 is a low-severity vulnerability in Elastic Elasticsearch, published on 22 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Elasticsearch versions before 6.8.13 and 7.9.2 contain a document disclosure flaw when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain complex queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.

Weakness: CWE-269 (Improper Privilege Management), CWE-270 (Privilege Context Switching Error)

## Which versions are affected by CVE-2020-7020?

5 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 6.8.13 |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 6.8.13 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.0.0 | 7.9.2 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.0.0 | 7.9.2 |
| `elasticsearch` | Bitnami | All versions | 6.8.13, 7.9.2 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2020-7020?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.13 or 7.9.2.

## Is CVE-2020-7020 being exploited?

There is no known exploitation of CVE-2020-7020 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7020 and fix it if it is affected.

What it is: CVE-2020-7020 is a low-severity vulnerability in Elastic Elasticsearch, published on 22 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7020 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.13
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.13
- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.9.2
- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.9.2
- elasticsearch (Bitnami): affected all versions; fixed in 6.8.13, 7.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7020/ (Markdown: https://insights.sbomify.com/CVE-2020-7020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7020
- OSV: https://osv.dev/vulnerability/CVE-2020-7020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7020/
Summaries are generated and may contain mistakes; the official description above is the record.
