CVE-2020-7059 OOB read in php_strip_tags_ex
An out-of-bounds read in PHP's fgetss function allows attackers to disclose sensitive memory contents or cause a crash.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7059?
CVE-2020-7059 is a medium-severity vulnerability in Debian Debian Linux, published on 10 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When using fgetss() function to read data with stripping tags, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause this function to read past the allocated buffer. This may lead to information disclosure or crash.
Weakness: CWE-125
Which versions are affected by CVE-2020-7059?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
php Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
php-min Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
Products include Debian Debian Linux, Opensuse Leap, Oracle Communications Diameter Signaling Router, Php Php, Tenable Tenable.sc.
How do I fix CVE-2020-7059?
Upgrade libphp to a fixed version for your release line: 7.2.27, 7.3.14 or 7.4.2.
Is CVE-2020-7059 being exploited?
There is no known exploitation of CVE-2020-7059 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2020-7059, BIT-php-2020-7059, BIT-php-min-2020-7059, CLSA-2025-1758102067, DEBIAN-CVE-2020-7059, GHSA-q8qf-vj8v-x7r9 and 1 more.