# CVE-2020-7059: OOB read in php_strip_tags_ex

> An out-of-bounds read in PHP's fgetss function allows attackers to disclose sensitive memory contents or cause a crash.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2020
- **Updated:** 17 Sep 2024
- **Also known as:** BIT-libphp-2020-7059, BIT-php-2020-7059, BIT-php-min-2020-7059, CLSA-2025-1758102067, DEBIAN-CVE-2020-7059, GHSA-q8qf-vj8v-x7r9, UBUNTU-CVE-2020-7059

## What is CVE-2020-7059?

CVE-2020-7059 is a medium-severity vulnerability in Debian Debian Linux, published on 10 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When using fgetss() function to read data with stripping tags, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause this function to read past the allocated buffer. This may lead to information disclosure or crash.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-7059?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
| `php` | Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
| `php-min` | Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |

Products: Debian Debian Linux, Opensuse Leap, Oracle Communications Diameter Signaling Router, Php Php, Tenable Tenable.sc.

## How do I fix CVE-2020-7059?

Upgrade libphp to a fixed version for your release line: 7.2.27, 7.3.14 or 7.4.2.

## Is CVE-2020-7059 being exploited?

There is no known exploitation of CVE-2020-7059 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7059 and fix it if it is affected.

What it is: CVE-2020-7059 is a medium-severity vulnerability in Debian Debian Linux, published on 10 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7059 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.2.0; fixed in 7.2.27, 7.3.14, 7.4.2
- php (Bitnami): affected from 7.2.0; fixed in 7.2.27, 7.3.14, 7.4.2
- php-min (Bitnami): affected from 7.2.0; fixed in 7.2.27, 7.3.14, 7.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7059/ (Markdown: https://insights.sbomify.com/CVE-2020-7059/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7059
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7059
- OSV: https://osv.dev/vulnerability/CVE-2020-7059

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7059/
Summaries are generated and may contain mistakes; the official description above is the record.
