CVE-2020-7060 global buffer-overflow in mbfl_filt_conv_big5_wchar
A buffer overflow in PHP's mbstring extension allows attackers to read memory or crash the application via crafted multibyte data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7060?
CVE-2020-7060 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 10 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When using certain mbstring functions to convert multibyte encodings, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause function mbfl_filt_conv_big5_wchar to read past the allocated buffer. This may lead to information disclosure or crash.
Weakness: CWE-125
Which versions are affected by CVE-2020-7060?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
php Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
php-min Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
Products include Debian Debian Linux, Opensuse Leap, Oracle Communications Diameter Signaling Router, Php Php, Tenable Tenable.sc.
How do I fix CVE-2020-7060?
Upgrade libphp to a fixed version for your release line: 7.2.27, 7.3.14 or 7.4.2.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2020-7060 being exploited?
There is no known exploitation of CVE-2020-7060 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2020-7060, BIT-php-2020-7060, BIT-php-min-2020-7060, DEBIAN-CVE-2020-7060, GHSA-ch28-9wjf-88gw, OESA-2021-1038 and 1 more.