# CVE-2020-7060: global buffer-overflow in mbfl_filt_conv_big5_wchar

> A buffer overflow in PHP's mbstring extension allows attackers to read memory or crash the application via crafted multibyte data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2020
- **Updated:** 17 Sep 2024
- **Also known as:** BIT-libphp-2020-7060, BIT-php-2020-7060, BIT-php-min-2020-7060, DEBIAN-CVE-2020-7060, GHSA-ch28-9wjf-88gw, OESA-2021-1038, UBUNTU-CVE-2020-7060

## What is CVE-2020-7060?

CVE-2020-7060 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 10 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When using certain mbstring functions to convert multibyte encodings, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause function mbfl_filt_conv_big5_wchar to read past the allocated buffer. This may lead to information disclosure or crash.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-7060?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
| `php` | Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |
| `php-min` | Bitnami | From 7.2.0 | 7.2.27, 7.3.14, 7.4.2 |

Products: Debian Debian Linux, Opensuse Leap, Oracle Communications Diameter Signaling Router, Php Php, Tenable Tenable.sc.

## How do I fix CVE-2020-7060?

Upgrade libphp to a fixed version for your release line: 7.2.27, 7.3.14 or 7.4.2.

## Is CVE-2020-7060 being exploited?

There is no known exploitation of CVE-2020-7060 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7060 and fix it if it is affected.

What it is: CVE-2020-7060 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 10 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7060 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.2.0; fixed in 7.2.27, 7.3.14, 7.4.2
- php (Bitnami): affected from 7.2.0; fixed in 7.2.27, 7.3.14, 7.4.2
- php-min (Bitnami): affected from 7.2.0; fixed in 7.2.27, 7.3.14, 7.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7060/ (Markdown: https://insights.sbomify.com/CVE-2020-7060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7060
- OSV: https://osv.dev/vulnerability/CVE-2020-7060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7060/
Summaries are generated and may contain mistakes; the official description above is the record.
