CVE-2020-7061 heap-buffer-overflow in phar_extract_file
A heap-buffer-overflow in PHP's phar extension on Windows allows attackers to cause crashes or disclose information via crafted PHAR files.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7061?
CVE-2020-7061 is a medium-severity memory corruption vulnerability in Php Php, published on 27 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 7.3.x below 7.3.15 and 7.4.x below 7.4.3, while extracting PHAR files on Windows using phar extension, certain content inside PHAR file could lead to one-byte read past the allocated buffer. This could potentially lead to information disclosure or crash.
Weakness: CWE-125
Which versions are affected by CVE-2020-7061?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
php Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
php-min Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
Products include Php Php, Tenable Tenable.sc.
How do I fix CVE-2020-7061?
Upgrade libphp to a fixed version for your release line: 7.2.28, 7.3.15 or 7.4.3.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2020-7061 being exploited?
There is no known exploitation of CVE-2020-7061 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as BIT-libphp-2020-7061, BIT-php-2020-7061, BIT-php-min-2020-7061, GHSA-q6h5-x7cx-j9jg.