# CVE-2020-7061: heap-buffer-overflow in phar_extract_file

> A heap-buffer-overflow in PHP's phar extension on Windows allows attackers to cause crashes or disclose information via crafted PHAR files.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2020
- **Updated:** 17 Sep 2024
- **Also known as:** BIT-libphp-2020-7061, BIT-php-2020-7061, BIT-php-min-2020-7061, GHSA-q6h5-x7cx-j9jg

## What is CVE-2020-7061?

CVE-2020-7061 is a medium-severity memory corruption vulnerability in Php Php, published on 27 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 7.3.x below 7.3.15 and 7.4.x below 7.4.3, while extracting PHAR files on Windows using phar extension, certain content inside PHAR file could lead to one-byte read past the allocated buffer. This could potentially lead to information disclosure or crash.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-7061?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
| `php` | Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
| `php-min` | Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |

Products: Php Php, Tenable Tenable.sc.

## How do I fix CVE-2020-7061?

Upgrade libphp to a fixed version for your release line: 7.2.28, 7.3.15 or 7.4.3.

## Is CVE-2020-7061 being exploited?

There is no known exploitation of CVE-2020-7061 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7061 and fix it if it is affected.

What it is: CVE-2020-7061 is a medium-severity memory corruption vulnerability in Php Php, published on 27 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7061 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.2.0; fixed in 7.2.28, 7.3.15, 7.4.3
- php (Bitnami): affected from 7.2.0; fixed in 7.2.28, 7.3.15, 7.4.3
- php-min (Bitnami): affected from 7.2.0; fixed in 7.2.28, 7.3.15, 7.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7061/ (Markdown: https://insights.sbomify.com/CVE-2020-7061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7061
- OSV: https://osv.dev/vulnerability/CVE-2020-7061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7061/
Summaries are generated and may contain mistakes; the official description above is the record.
