CVE-2020-7063 Files added to tar with Phar::buildFromIterator have all-access permissions
PHP's Phar::buildFromIterator assigns overly permissive file permissions to archive contents, potentially exposing sensitive data or enabling privilege escalation upon extraction.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-7063?
CVE-2020-7063 is a medium-severity vulnerability in Debian Debian Linux, published on 27 Feb 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
In PHP versions 7.2.x below 7.2.28, 7.3.x below 7.3.15 and 7.4.x below 7.4.3, when creating PHAR archive using PharData::buildFromIterator() function, the files are added with default permissions (0666, or all access) even if the original files on the filesystem were with more restrictive permissions. This may result in files having more lax permissions than intended when such archive is extracted.
Weakness: CWE-281
Which versions are affected by CVE-2020-7063?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
php Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
php-min Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
Products include Debian Debian Linux, Opensuse Leap, Php Php, Tenable Tenable.sc.
How do I fix CVE-2020-7063?
Upgrade libphp to a fixed version for your release line: 7.2.28, 7.3.15 or 7.4.3.
Is CVE-2020-7063 being exploited?
There is no known exploitation of CVE-2020-7063 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2020-7063, BIT-php-2020-7063, BIT-php-min-2020-7063, DEBIAN-CVE-2020-7063, GHSA-rm3c-r6h9-r9rg, UBUNTU-CVE-2020-7063.