# CVE-2020-7063: Files added to tar with Phar::buildFromIterator have all-access permissions

> PHP's Phar::buildFromIterator assigns overly permissive file permissions to archive contents, potentially exposing sensitive data or enabling privilege escalation upon extraction.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2020
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-libphp-2020-7063, BIT-php-2020-7063, BIT-php-min-2020-7063, DEBIAN-CVE-2020-7063, GHSA-rm3c-r6h9-r9rg, UBUNTU-CVE-2020-7063

## What is CVE-2020-7063?

CVE-2020-7063 is a medium-severity vulnerability in Debian Debian Linux, published on 27 Feb 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In PHP versions 7.2.x below 7.2.28, 7.3.x below 7.3.15 and 7.4.x below 7.4.3, when creating PHAR archive using PharData::buildFromIterator() function, the files are added with default permissions (0666, or all access) even if the original files on the filesystem were with more restrictive permissions. This may result in files having more lax permissions than intended when such archive is extracted.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2020-7063?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
| `php` | Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |
| `php-min` | Bitnami | From 7.2.0 | 7.2.28, 7.3.15, 7.4.3 |

Products: Debian Debian Linux, Opensuse Leap, Php Php, Tenable Tenable.sc.

## How do I fix CVE-2020-7063?

Upgrade libphp to a fixed version for your release line: 7.2.28, 7.3.15 or 7.4.3.

## Is CVE-2020-7063 being exploited?

There is no known exploitation of CVE-2020-7063 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7063 and fix it if it is affected.

What it is: CVE-2020-7063 is a medium-severity vulnerability in Debian Debian Linux, published on 27 Feb 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-7063 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.2.0; fixed in 7.2.28, 7.3.15, 7.4.3
- php (Bitnami): affected from 7.2.0; fixed in 7.2.28, 7.3.15, 7.4.3
- php-min (Bitnami): affected from 7.2.0; fixed in 7.2.28, 7.3.15, 7.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7063/ (Markdown: https://insights.sbomify.com/CVE-2020-7063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7063
- OSV: https://osv.dev/vulnerability/CVE-2020-7063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7063/
Summaries are generated and may contain mistakes; the official description above is the record.
