CVE-2020-7064 Use-of-uninitialized-value in exif
Malicious EXIF data can cause PHP to read uninitialized memory, potentially leading to information disclosure or application crashes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7064?
CVE-2020-7064 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 7.2.x below 7.2.9, 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while parsing EXIF data with exif_read_data() function, it is possible for malicious data to cause PHP to read one byte of uninitialized memory. This could potentially lead to information disclosure or crash.
Weakness: CWE-125
Which versions are affected by CVE-2020-7064?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.2.0 | 7.2.29, 7.3.16, 7.4.4 |
php Bitnami | From 7.2.0 | 7.2.29, 7.3.16, 7.4.4 |
php-min Bitnami | From 7.2.0 | 7.2.29, 7.3.16, 7.4.4 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Opensuse Leap, Php Php, Tenable Tenable.sc.
How do I fix CVE-2020-7064?
Upgrade libphp to a fixed version for your release line: 7.2.29, 7.3.16 or 7.4.4.
Is CVE-2020-7064 being exploited?
There is no known exploitation of CVE-2020-7064 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-libphp-2020-7064, BIT-php-2020-7064, BIT-php-min-2020-7064, DEBIAN-CVE-2020-7064, GHSA-rw73-mxr4-6595, UBUNTU-CVE-2020-7064.