# CVE-2020-7064: Use-of-uninitialized-value in exif

> Malicious EXIF data can cause PHP to read uninitialized memory, potentially leading to information disclosure or application crashes.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2020
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-libphp-2020-7064, BIT-php-2020-7064, BIT-php-min-2020-7064, DEBIAN-CVE-2020-7064, GHSA-rw73-mxr4-6595, UBUNTU-CVE-2020-7064

## What is CVE-2020-7064?

CVE-2020-7064 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 7.2.x below 7.2.9, 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while parsing EXIF data with exif_read_data() function, it is possible for malicious data to cause PHP to read one byte of uninitialized memory. This could potentially lead to information disclosure or crash.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-7064?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.2.0 | 7.2.29, 7.3.16, 7.4.4 |
| `php` | Bitnami | From 7.2.0 | 7.2.29, 7.3.16, 7.4.4 |
| `php-min` | Bitnami | From 7.2.0 | 7.2.29, 7.3.16, 7.4.4 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Opensuse Leap, Php Php, Tenable Tenable.sc.

## How do I fix CVE-2020-7064?

Upgrade libphp to a fixed version for your release line: 7.2.29, 7.3.16 or 7.4.4.

## Is CVE-2020-7064 being exploited?

There is no known exploitation of CVE-2020-7064 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7064 and fix it if it is affected.

What it is: CVE-2020-7064 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7064 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.2.0; fixed in 7.2.29, 7.3.16, 7.4.4
- php (Bitnami): affected from 7.2.0; fixed in 7.2.29, 7.3.16, 7.4.4
- php-min (Bitnami): affected from 7.2.0; fixed in 7.2.29, 7.3.16, 7.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7064/ (Markdown: https://insights.sbomify.com/CVE-2020-7064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7064
- OSV: https://osv.dev/vulnerability/CVE-2020-7064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7064/
Summaries are generated and may contain mistakes; the official description above is the record.
