CVE-2020-7065 mb_strtolower (UTF-32LE): stack-buffer-overflow at php_unicode_tolower_full
A stack-buffer-overflow in PHP's mb_strtolower function with UTF-32LE encoding allows attackers to cause memory corruption, crashes, or potentially execute arbitrary code.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7065?
CVE-2020-7065 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using mb_strtolower() function with UTF-32LE encoding, certain invalid strings could cause PHP to overwrite stack-allocated buffer. This could lead to memory corruption, crashes and potentially code execution.
Which versions are affected by CVE-2020-7065?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.3.0 | 7.3.16, 7.4.4 |
php Bitnami | From 7.3.0 | 7.3.16, 7.4.4 |
php-min Bitnami | From 7.3.0 | 7.3.16, 7.4.4 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Php Php, Tenable Tenable.sc.
How do I fix CVE-2020-7065?
Upgrade libphp to a fixed version for your release line: 7.3.16 or 7.4.4.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2020-7065 being exploited?
There is no known exploitation of CVE-2020-7065 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-libphp-2020-7065, BIT-php-2020-7065, BIT-php-min-2020-7065, DEBIAN-CVE-2020-7065, GHSA-hpqg-gp78-43q4, UBUNTU-CVE-2020-7065.