{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-7065 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 7.3.16 or 7.4.4.","what":"CVE-2020-7065 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7065 and fix it if it is affected.\n\nWhat it is: CVE-2020-7065 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7065 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 7.3.0; fixed in 7.3.16, 7.4.4\n- php (Bitnami): affected from 7.3.0; fixed in 7.3.16, 7.4.4\n- php-min (Bitnami): affected from 7.3.0; fixed in 7.3.16, 7.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7065/ (Markdown: https://insights.sbomify.com/CVE-2020-7065/index.md)","id":"CVE-2020-7065","markdown":"https://insights.sbomify.com/CVE-2020-7065/index.md","name":"CVE-2020-7065","record":{"aliases":["BIT-libphp-2020-7065","BIT-php-2020-7065","BIT-php-min-2020-7065","DEBIAN-CVE-2020-7065","GHSA-hpqg-gp78-43q4","UBUNTU-CVE-2020-7065"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"none","summary":"A stack-buffer-overflow in PHP's mb_strtolower function with UTF-32LE encoding allows attackers to cause memory corruption, crashes, or potentially execute arbitrary code.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"php","vendor":"php"},{"product":"tenable.sc","vendor":"tenable"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"In PHP versions 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using mb_strtolower() function with UTF-32LE encoding, certain invalid strings could cause PHP to overwrite stack-allocated buffer. This could lead to memory corruption, crashes and potentially code execution.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"mb_strtolower (UTF-32LE): stack-buffer-overflow at php_unicode_tolower_full","id":"CVE-2020-7065","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","php:php"],"type":"memory_corruption","year":"2020"},"n_packages":3,"n_references":8,"next":{"headline":"get_headers() silently truncates after a null byte","id":"CVE-2020-7066"},"packages":[{"ecosystem":"Bitnami","fixed":["7.3.16","7.4.4"],"introduced":["7.3.0","7.4.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2020-7065"},{"ecosystem":"Bitnami","fixed":["7.3.16","7.4.4"],"introduced":["7.3.0","7.4.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2020-7065"},{"ecosystem":"Bitnami","fixed":["7.3.16","7.4.4"],"introduced":["7.3.0","7.4.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2020-7065"}],"prev":{"headline":"Use-of-uninitialized-value in exif","id":"CVE-2020-7064"},"products":["PHP"],"published":"2020-04-01","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["PHP Group"]},"summary":"A stack-buffer-overflow in PHP's mb_strtolower function with UTF-32LE encoding allows attackers to cause memory corruption, crashes, or potentially execute arbitrary code.","url":"https://insights.sbomify.com/CVE-2020-7065/"}