CVE-2020-7067 OOB Read in urldecode()
An out-of-bounds read in PHP's urldecode() function can cause crashes or leak memory when EBCDIC support is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7067?
CVE-2020-7067 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 27 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 7.2.x below 7.2.30, 7.3.x below 7.3.17 and 7.4.x below 7.4.5, if PHP is compiled with EBCDIC support (uncommon), urldecode() function can be made to access locations past the allocated memory, due to erroneously using signed numbers as array indexes.
Which versions are affected by CVE-2020-7067?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.2.0 | 7.2.30, 7.3.17, 7.4.5 |
php Bitnami | From 7.2.0 | 7.2.30, 7.3.17, 7.4.5 |
php-min Bitnami | From 7.2.0 | 7.2.30, 7.3.17, 7.4.5 |
Products include Debian Debian Linux, Oracle Communications Diameter Signaling Router, Php Php, Tenable Tenable.sc.
How do I fix CVE-2020-7067?
Upgrade libphp to a fixed version for your release line: 7.2.30, 7.3.17 or 7.4.5.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2020-7067 being exploited?
There is no known exploitation of CVE-2020-7067 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2020-7067, BIT-php-2020-7067, BIT-php-min-2020-7067, CLSA-2025-1758193800, DEBIAN-CVE-2020-7067, GHSA-8hqm-3r2c-qg9c and 1 more.