CVE-2020-7068 Use of freed hash key in the phar_parse_zipfile function
Attackers can trigger a use-after-free in PHP's phar extension via crafted ZIP files, causing crashes or information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7068?
CVE-2020-7068 is a medium-severity use after free vulnerability in Debian Debian Linux, published on 9 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 7.2.x below 7.2.33, 7.3.x below 7.3.21 and 7.4.x below 7.4.9, while processing PHAR files using phar extension, phar_parse_zipfile could be tricked into accessing freed memory, which could lead to a crash or information disclosure.
Weakness: CWE-416
Which versions are affected by CVE-2020-7068?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.2.0 | 7.2.33, 7.3.21, 7.4.9 |
php Bitnami | From 7.2.0 | 7.2.33, 7.3.21, 7.4.9 |
php-min Bitnami | From 7.2.0 | 7.2.33, 7.3.21, 7.4.9 |
Linux distribution packages (15)
php7 SUSE:Linux Enterprise Module for Package Hub 15 SP1 | All versions | 7.2.5-4.61.1 |
php7 SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 7.4.6-3.6.1 |
php5 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 5.5.14-109.79.1 |
php7 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.0.7-50.97.1 |
php72 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.2.5-1.49.1 |
php74 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.4.6-1.8.1 |
php7 SUSE:Linux Enterprise Module for Web and Scripting 15 SP1 | All versions | 7.2.5-4.61.1 |
php7 SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 7.4.6-3.6.1 |
php7 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.0.7-50.97.1 |
php72 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.2.5-1.49.1 |
php74 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.4.6-1.8.1 |
php7 openSUSE:Leap 15.1 | All versions | 7.2.5-lp151.6.32.1 |
php7-test openSUSE:Leap 15.1 | All versions | 7.2.5-lp151.6.32.1 |
php7 openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.6.1 |
php7-test openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.6.1 |
Products include Debian Debian Linux, Php Php, Tenable Tenable.sc.
How do I fix CVE-2020-7068?
Upgrade libphp to a fixed version for your release line: 7.2.33, 7.3.21 or 7.4.9.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2020-7068 being exploited?
There is no known exploitation of CVE-2020-7068 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2020-7068, BIT-php-2020-7068, BIT-php-min-2020-7068, DEBIAN-CVE-2020-7068, DLA-2345-1, GHSA-vc9g-5348-gqwv and 9 more.