# CVE-2020-7068: Use of freed hash key in the phar_parse_zipfile function

> Attackers can trigger a use-after-free in PHP's phar extension via crafted ZIP files, causing crashes or information disclosure.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2020
- **Updated:** 17 Sep 2024
- **Also known as:** BIT-libphp-2020-7068, BIT-php-2020-7068, BIT-php-min-2020-7068, DEBIAN-CVE-2020-7068, DLA-2345-1, GHSA-vc9g-5348-gqwv, SUSE-SU-2020:2403-1, SUSE-SU-2020:2404-1, SUSE-SU-2020:2405-1, SUSE-SU-2020:2455-1, SUSE-SU-2020:2456-1, SUSE-SU-2020:2477-1, UBUNTU-CVE-2020-7068, openSUSE-SU-2020:1354-1, openSUSE-SU-2020:1356-1

## What is CVE-2020-7068?

CVE-2020-7068 is a medium-severity use after free vulnerability in Debian Debian Linux, published on 9 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 7.2.x below 7.2.33, 7.3.x below 7.3.21 and 7.4.x below 7.4.9, while processing PHAR files using phar extension, phar_parse_zipfile could be tricked into accessing freed memory, which could lead to a crash or information disclosure.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2020-7068?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.2.0 | 7.2.33, 7.3.21, 7.4.9 |
| `php` | Bitnami | From 7.2.0 | 7.2.33, 7.3.21, 7.4.9 |
| `php-min` | Bitnami | From 7.2.0 | 7.2.33, 7.3.21, 7.4.9 |
| `php7` | SUSE:Linux Enterprise Module for Package Hub 15 SP1 | All versions | 7.2.5-4.61.1 |
| `php7` | SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 7.4.6-3.6.1 |
| `php5` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 5.5.14-109.79.1 |
| `php7` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.0.7-50.97.1 |
| `php72` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.2.5-1.49.1 |
| `php74` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.4.6-1.8.1 |
| `php7` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP1 | All versions | 7.2.5-4.61.1 |
| `php7` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 7.4.6-3.6.1 |
| `php7` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.0.7-50.97.1 |
| `php72` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.2.5-1.49.1 |
| `php74` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.4.6-1.8.1 |
| `php7` | openSUSE:Leap 15.1 | All versions | 7.2.5-lp151.6.32.1 |
| `php7-test` | openSUSE:Leap 15.1 | All versions | 7.2.5-lp151.6.32.1 |
| `php7` | openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.6.1 |
| `php7-test` | openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.6.1 |

Products: Debian Debian Linux, Php Php, Tenable Tenable.sc.

## How do I fix CVE-2020-7068?

Upgrade libphp to a fixed version for your release line: 7.2.33, 7.3.21 or 7.4.9.

## Is CVE-2020-7068 being exploited?

There is no known exploitation of CVE-2020-7068 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7068 and fix it if it is affected.

What it is: CVE-2020-7068 is a medium-severity use after free vulnerability in Debian Debian Linux, published on 9 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7068 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.2.0; fixed in 7.2.33, 7.3.21, 7.4.9
- php (Bitnami): affected from 7.2.0; fixed in 7.2.33, 7.3.21, 7.4.9
- php-min (Bitnami): affected from 7.2.0; fixed in 7.2.33, 7.3.21, 7.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7068/ (Markdown: https://insights.sbomify.com/CVE-2020-7068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7068
- OSV: https://osv.dev/vulnerability/CVE-2020-7068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7068/
Summaries are generated and may contain mistakes; the official description above is the record.
