CVE-2020-7069 Wrong ciphertext/tag in AES-CCM encryption for a 12 bytes IV
PHP's AES-CCM encryption incorrectly uses only part of the IV, leading to weak encryption and potential data exposure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-7069?
CVE-2020-7069 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 2 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In PHP versions 7.2.x below 7.2.34, 7.3.x below 7.3.23 and 7.4.x below 7.4.11, when AES-CCM mode is used with openssl_encrypt() function with 12 bytes IV, only first 7 bytes of the IV is actually used. This can lead to both decreased security and incorrect encryption data.
Which versions are affected by CVE-2020-7069?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.2.0 | 7.2.34, 7.3.23, 7.4.11 |
php Bitnami | From 7.2.0 | 7.2.34, 7.3.23, 7.4.11 |
php-min Bitnami | From 7.2.0 | 7.2.34, 7.3.23, 7.4.11 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Netapp Clustered Data Ontap, Opensuse Leap, Oracle Communications Diameter Signaling Router and 2 more.
How do I fix CVE-2020-7069?
Upgrade libphp to a fixed version for your release line: 7.2.34, 7.3.23 or 7.4.11.
Is CVE-2020-7069 being exploited?
There is no known exploitation of CVE-2020-7069 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-libphp-2020-7069, BIT-php-2020-7069, BIT-php-min-2020-7069, DEBIAN-CVE-2020-7069, GHSA-v3rw-94vx-73w6, UBUNTU-CVE-2020-7069.