CVE-2020-7071 FILTER_VALIDATE_URL accepts URLs with invalid userinfo
PHP's URL validation incorrectly accepts invalid userinfo, potentially causing downstream parsers to misinterpret URLs and process wrong data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7071?
CVE-2020-7071 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 7.3.x below 7.3.26, 7.4.x below 7.4.14 and 8.0.0, when validating URL with functions like filter_var($url, FILTER_VALIDATE_URL), PHP will accept an URL with invalid password as valid URL. This may lead to functions that rely on URL being valid to mis-parse the URL and produce wrong data as components of the URL.
Weakness: CWE-20
Which versions are affected by CVE-2020-7071?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.3.0 | 7.3.26, 7.4.14, 8.0.1 |
php Bitnami | From 7.3.0 | 7.3.26, 7.4.14, 8.0.1 |
php-min Bitnami | From 7.3.0 | 7.3.26, 7.4.14, 8.0.1 |
Linux distribution packages (10)
php7 SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 7.4.6-3.14.2 |
php72 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.2.5-1.57.1 |
php74 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.4.6-1.16.1 |
php7 SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 7.4.6-3.14.2 |
php72 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.2.5-1.57.1 |
php74 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.4.6-1.16.1 |
php7 openSUSE:Leap 15.1 | All versions | 7.2.5-lp151.6.39.1 |
php7-test openSUSE:Leap 15.1 | All versions | 7.2.5-lp151.6.39.1 |
php7 openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.12.1 |
php7-test openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.12.1 |
Products include Debian Debian Linux, Netapp Clustered Data Ontap, Php Php.
How do I fix CVE-2020-7071?
Upgrade libphp to a fixed version for your release line: 7.3.26, 7.4.14 or 8.0.1.
Is CVE-2020-7071 being exploited?
There is no known exploitation of CVE-2020-7071 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2020-7071, BIT-php-2020-7071, BIT-php-min-2020-7071, DEBIAN-CVE-2020-7071, ECHO-9a1a-f71f-0da6, GHSA-grxx-qh3p-vx7g and 7 more.