# CVE-2020-7071: FILTER_VALIDATE_URL accepts URLs with invalid userinfo

> PHP's URL validation incorrectly accepts invalid userinfo, potentially causing downstream parsers to misinterpret URLs and process wrong data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2021
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-libphp-2020-7071, BIT-php-2020-7071, BIT-php-min-2020-7071, DEBIAN-CVE-2020-7071, ECHO-9a1a-f71f-0da6, GHSA-grxx-qh3p-vx7g, MGASA-2021-0025, SUSE-SU-2021:0124-1, SUSE-SU-2021:0125-1, SUSE-SU-2021:0126-1, UBUNTU-CVE-2020-7071, openSUSE-SU-2021:0101-1, openSUSE-SU-2021:0106-1

## What is CVE-2020-7071?

CVE-2020-7071 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 7.3.x below 7.3.26, 7.4.x below 7.4.14 and 8.0.0, when validating URL with functions like filter_var($url, FILTER_VALIDATE_URL), PHP will accept an URL with invalid password as valid URL. This may lead to functions that rely on URL being valid to mis-parse the URL and produce wrong data as components of the URL.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-7071?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.3.0 | 7.3.26, 7.4.14, 8.0.1 |
| `php` | Bitnami | From 7.3.0 | 7.3.26, 7.4.14, 8.0.1 |
| `php-min` | Bitnami | From 7.3.0 | 7.3.26, 7.4.14, 8.0.1 |
| `php7` | SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 7.4.6-3.14.2 |
| `php72` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.2.5-1.57.1 |
| `php74` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.4.6-1.16.1 |
| `php7` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 7.4.6-3.14.2 |
| `php72` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.2.5-1.57.1 |
| `php74` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.4.6-1.16.1 |
| `php7` | openSUSE:Leap 15.1 | All versions | 7.2.5-lp151.6.39.1 |
| `php7-test` | openSUSE:Leap 15.1 | All versions | 7.2.5-lp151.6.39.1 |
| `php7` | openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.12.1 |
| `php7-test` | openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.12.1 |

Products: Debian Debian Linux, Netapp Clustered Data Ontap, Php Php.

## How do I fix CVE-2020-7071?

Upgrade libphp to a fixed version for your release line: 7.3.26, 7.4.14 or 8.0.1.

## Is CVE-2020-7071 being exploited?

There is no known exploitation of CVE-2020-7071 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7071 and fix it if it is affected.

What it is: CVE-2020-7071 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7071 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.3.0; fixed in 7.3.26, 7.4.14, 8.0.1
- php (Bitnami): affected from 7.3.0; fixed in 7.3.26, 7.4.14, 8.0.1
- php-min (Bitnami): affected from 7.3.0; fixed in 7.3.26, 7.4.14, 8.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7071/ (Markdown: https://insights.sbomify.com/CVE-2020-7071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7071
- OSV: https://osv.dev/vulnerability/CVE-2020-7071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7071/
Summaries are generated and may contain mistakes; the official description above is the record.
