# CVE-2020-7130: Information disclosure in HPE OneView Global Dashboard

> Remote attackers can access sensitive information due to open firewall ports in HPE OneView Global Dashboard after installation or upgrade.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-x8mr-64rx-qcvm

## What is CVE-2020-7130?

CVE-2020-7130 is a high-severity vulnerability in HPE OneView Global Dashboard, published on 4 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HPE OneView Global Dashboard (OVGD) 1.9 has a remote information disclosure vulnerability. HPE OneView Global Dashboard - After Upgrade or Install of OVGD Version 1.9, Appliance Firewall May Leave Ports Open. This is resolved in OVGD 1.91 or later.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-7130?

It affects 1 product.


Products: Hp Oneview Global Dashboard.

## How do I fix CVE-2020-7130?

No fix has been published for CVE-2020-7130 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-7130 being exploited?

There is no known exploitation of CVE-2020-7130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7130 and fix it if it is affected.

What it is: CVE-2020-7130 is a high-severity vulnerability in HPE OneView Global Dashboard, published on 4 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7130 in the wild and no public exploit code.

Affected product: HPE OneView Global Dashboard. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7130/ (Markdown: https://insights.sbomify.com/CVE-2020-7130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7130
- OSV: https://osv.dev/vulnerability/CVE-2020-7130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7130/
Summaries are generated and may contain mistakes; the official description above is the record.
