# CVE-2020-7209: Code injection in LinuxKI

> Remote attackers can execute arbitrary code on systems running vulnerable versions of the LinuxKI administration tool.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4p9q-r6vf-q2pr

## What is CVE-2020-7209?

CVE-2020-7209 is a critical code injection vulnerability in LinuxKI, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LinuxKI v6.0-1 and earlier is vulnerable to an remote code execution which is resolved in release 6.0-2.

## Which versions are affected by CVE-2020-7209?

It affects 1 product.


Products: Hp Linuxki.

## How do I fix CVE-2020-7209?

No fix has been published for CVE-2020-7209 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-7209 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-7209 exists.

Public exploit code:

- LinuxKI Toolset 6.01 Remote Command Execution (metasploit)
- HP LinuxKI 6.01 - Remote Command Injection (exploitdb)
- LinuxKI Toolset <= 6.01 - Remote Command Execution (nuclei): http/cves/2020/CVE-2020-7209.yaml

## Other vulnerabilities in LinuxKI

- [CVE-2020-7208](https://insights.sbomify.com/CVE-2020-7208/): Cross-site scripting in LinuxKI (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7209 and fix it if it is affected.

What it is: CVE-2020-7209 is a critical code injection vulnerability in LinuxKI, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-7209 exists.

Affected product: LinuxKI. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7209/ (Markdown: https://insights.sbomify.com/CVE-2020-7209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7209
- OSV: https://osv.dev/vulnerability/CVE-2020-7209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7209/
Summaries are generated and may contain mistakes; the official description above is the record.
