CVE-2020-7218 Allocation of Resources Without Limits or Throttling in HashiCorp Nomad

High 7.5 Published Updated

Unauthenticated attackers can cause denial of service in HashiCorp Nomad by exploiting unbounded resource usage in HTTP/RPC services.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-7218?

CVE-2020-7218 is a high-severity denial of service vulnerability in n/a, published on 31 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

HashiCorp Nomad and Nonad Enterprise up to 0.10.2 HTTP/RPC services allowed unbounded resource usage, and were susceptible to unauthenticated denial of service. Fixed in 0.10.3.

Weakness: CWE-770

Which versions are affected by CVE-2020-7218?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoAll versions0.10.3
github.com/hashicorp/nomad GoAll versions0.10.3
github.com/hashicorp/nomad GoAll versions0.10.3

Products include Hashicorp Nomad.

How do I fix CVE-2020-7218?

Upgrade github.com/hashicorp/nomad to 0.10.3 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-7218 being exploited?

There is no known exploitation of CVE-2020-7218 in the wild and no public exploit code.

Sources

Also known as GHSA-h43v-26r7-7j4c, GO-2022-0840, UBUNTU-CVE-2020-7218.

Is CVE-2020-7218 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free