# CVE-2020-7218: Allocation of Resources Without Limits or Throttling in HashiCorp Nomad

> Unauthenticated attackers can cause denial of service in HashiCorp Nomad by exploiting unbounded resource usage in HTTP/RPC services.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h43v-26r7-7j4c, GO-2022-0840, UBUNTU-CVE-2020-7218

## What is CVE-2020-7218?

CVE-2020-7218 is a high-severity denial of service vulnerability in n/a, published on 31 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Nomad and Nonad Enterprise up to 0.10.2 HTTP/RPC services allowed unbounded resource usage, and were susceptible to unauthenticated denial of service. Fixed in 0.10.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2020-7218?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | All versions | 0.10.3 |
| `github.com/hashicorp/nomad` | Go | All versions | 0.10.3 |
| `github.com/hashicorp/nomad` | Go | All versions | 0.10.3 |

Products: Hashicorp Nomad.

## How do I fix CVE-2020-7218?

Upgrade github.com/hashicorp/nomad to 0.10.3 or later.

## Is CVE-2020-7218 being exploited?

There is no known exploitation of CVE-2020-7218 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7218 and fix it if it is affected.

What it is: CVE-2020-7218 is a high-severity denial of service vulnerability in n/a, published on 31 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7218 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 0.10.3
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 0.10.3
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 0.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7218/ (Markdown: https://insights.sbomify.com/CVE-2020-7218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7218
- OSV: https://osv.dev/vulnerability/CVE-2020-7218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7218/
Summaries are generated and may contain mistakes; the official description above is the record.
