# CVE-2020-7221: Privilege escalation in n/a

> A local attacker with mysql user access can escalate privileges to root via unsafe file permissions in MariaDB's installation script.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mariadb-2020-7221, BIT-mariadb-min-2020-7221, BIT-mysql-client-2020-7221, GHSA-3xr8-q83f-2wqp, UBUNTU-CVE-2020-7221

## What is CVE-2020-7221?

CVE-2020-7221 is a high-severity vulnerability in Mariadb Mariadb, published on 4 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

mysql_install_db in MariaDB 10.4.7 through 10.4.11 allows privilege escalation from the mysql user account to root because chown and chmod are performed unsafely, as demonstrated by a symlink attack on a chmod 04755 of auth_pam_tool_dir/auth_pam_tool. NOTE: this does not affect the Oracle MySQL product, which implements mysql_install_db differently.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2020-7221?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.4.7 | 10.4.12 |
| `mariadb-min` | Bitnami | From 10.4.7 to 10.4.11 | None |
| `mysql-client` | Bitnami | From 10.4.7 | 10.4.12 |

Products: Mariadb Mariadb.

## How do I fix CVE-2020-7221?

Upgrade mariadb to 10.4.12 or later.

## Is CVE-2020-7221 being exploited?

There is no known exploitation of CVE-2020-7221 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7221 and fix it if it is affected.

What it is: CVE-2020-7221 is a high-severity vulnerability in Mariadb Mariadb, published on 4 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7221 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.4.7; fixed in 10.4.12
- mariadb-min (Bitnami): affected from 10.4.7 up to 10.4.11; no fix listed
- mysql-client (Bitnami): affected from 10.4.7; fixed in 10.4.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7221/ (Markdown: https://insights.sbomify.com/CVE-2020-7221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7221
- OSV: https://osv.dev/vulnerability/CVE-2020-7221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7221/
Summaries are generated and may contain mistakes; the official description above is the record.
