# CVE-2020-7238: HTTP Request Smuggling in Netty

> Netty allows HTTP request smuggling via mishandled Transfer-Encoding whitespace, enabling cache poisoning or security bypasses.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-7238, GHSA-ff2w-cq2g-wv5f, UBUNTU-CVE-2020-7238

## What is CVE-2020-7238?

CVE-2020-7238 is a high-severity vulnerability in Debian Debian Linux, published on 27 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty 4.1.43.Final allows HTTP Request Smuggling because it mishandles Transfer-Encoding whitespace (such as a [space]Transfer-Encoding:chunked line) and a later Content-Length header. This issue exists because of an incomplete fix for CVE-2019-16869.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2020-7238?

2 open source packages ship an affected version, including io.netty:netty-handler. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-handler` | Maven | From 4.1.43 | 4.1.45 |
| `io.netty:netty-handler` | Maven | From 4.1.43 | 4.1.45 |

Products: Debian Debian Linux, Fedoraproject Fedora, Netty Netty, Redhat Jboss Enterprise Application Platform, Redhat Jboss Enterprise Application Platform Text-Only Advisories, Redhat Openshift Application Runtimes Text-Only Advisories.

## How do I fix CVE-2020-7238?

Upgrade io.netty:netty-handler to 4.1.45 or later.

## Is CVE-2020-7238 being exploited?

There is no known exploitation of CVE-2020-7238 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7238 and fix it if it is affected.

What it is: CVE-2020-7238 is a high-severity vulnerability in Debian Debian Linux, published on 27 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7238 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-handler (Maven): affected from 4.1.43; fixed in 4.1.45
- io.netty:netty-handler (Maven): affected from 4.1.43; fixed in 4.1.45

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7238/ (Markdown: https://insights.sbomify.com/CVE-2020-7238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7238
- OSV: https://osv.dev/vulnerability/CVE-2020-7238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7238/
Summaries are generated and may contain mistakes; the official description above is the record.
