{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-7519 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2020-7519 yet. Limit exposure of the affected software until one is available.","what":"CVE-2020-7519 is a high-severity vulnerability in Easergy Builder (Version 1.4.7.2 and older), published on 23 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7519 and fix it if it is affected.\n\nWhat it is: CVE-2020-7519 is a high-severity vulnerability in Easergy Builder (Version 1.4.7.2 and older), published on 23 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7519 in the wild and no public exploit code.\n\nAffected product: Easergy Builder (Version 1.4.7.2 and older). No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7519/ (Markdown: https://insights.sbomify.com/CVE-2020-7519/index.md)","id":"CVE-2020-7519","markdown":"https://insights.sbomify.com/CVE-2020-7519/index.md","name":"CVE-2020-7519","record":{"aliases":["GHSA-q3h2-mgqx-8rg3"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Easergy Builder","requires_auth":"none","summary":"Weak password requirements in Easergy Builder allow attackers to compromise user accounts.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"schneider","cpe":[{"product":"easergy_builder","vendor":"schneider-electric"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-521","name":"Weak Password Requirements"}],"description":"A CWE-521: Weak Password Requirements vulnerability exists in Easergy Builder (Version 1.4.7.2 and older) which could allow an attacker to compromise a user account.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Weak cryptography in Easergy Builder (Version 1.4.7.2 and older)","id":"CVE-2020-7519","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"weak_cryptography","year":"2020"},"n_packages":0,"n_references":1,"next":{"headline":"Open redirect in Schneider Electric Software Update (SESU) V2.4.0 and prior.","id":"CVE-2020-7520"},"packages":[],"prev":{"headline":"Other in Easergy Builder (Version 1.4.7.2 and older)","id":"CVE-2020-7518"},"products":["Easergy Builder (Version 1.4.7.2 and older)"],"published":"2020-07-23","related":[{"cvss_score":7.8,"headline":"Weak cryptography in Easergy Builder (Version 1.4.7.2 and older)","id":"CVE-2020-7514","kev_date_added":null,"published":"2020-07-23"},{"cvss_score":7.8,"headline":"Hardcoded credentials in Easergy Builder V1.4.7.2 and prior","id":"CVE-2020-7515","kev_date_added":null,"published":"2020-07-23"},{"cvss_score":7.8,"headline":"Information disclosure in Easergy Builder V1.4.7.2 and prior","id":"CVE-2020-7516","kev_date_added":null,"published":"2020-07-23"},{"cvss_score":7.5,"headline":"Other in Easergy Builder (Version 1.4.7.2 and older)","id":"CVE-2020-7518","kev_date_added":null,"published":"2020-07-23"},{"cvss_score":5.5,"headline":"Information disclosure in Easergy Builder (Version 1.4.7.2 and older)","id":"CVE-2020-7517","kev_date_added":null,"published":"2020-07-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Weak password requirements in Easergy Builder allow attackers to compromise user accounts.","url":"https://insights.sbomify.com/CVE-2020-7519/"}