# CVE-2020-7595: libxml as used in Nokogiri has an infinite loop in a certain end-of-file situation

> An attacker can cause a denial of service via an infinite loop in libxml2 when processing specific end-of-file conditions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2020
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2020-7595, DEBIAN-CVE-2020-7595, ECHO-330d-8331-b637, GHSA-7553-jr98-vx47, JLSEC-2025-68, UBUNTU-CVE-2020-7595

## What is CVE-2020-7595?

CVE-2020-7595 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 21 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmlStringLenDecodeEntities in parser.c in libxml2 2.9.10 has an infinite loop in a certain end-of-file situation.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2020-7595?

2 open source packages ship an affected version, including nokogiri. It affects 24 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.10.8 |
| `nokogiri` | RubyGems | All versions | 1.10.8 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Netapp Clustered Data Ontap, Netapp H300e Firmware, Netapp H300s Firmware, Netapp H410c Firmware, Netapp H410s Firmware, Netapp H500e Firmware, Netapp H500s Firmware, Netapp H700e Firmware, Netapp H700s Firmware, Netapp Smi-S Provider, Netapp Snapdrive, Netapp Steelstore Cloud Integrated Storage, Netapp Symantec Netbackup, Oracle Communications Cloud Native Core Network Function Cloud Native Environment, Oracle Enterprise Manager Base Platform, Oracle Enterprise Manager Ops Center, Oracle Mysql Workbench and 4 more.

## How do I fix CVE-2020-7595?

Upgrade nokogiri to 1.10.8 or later.

## Is CVE-2020-7595 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-7595 exists.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7595 and fix it if it is affected.

What it is: CVE-2020-7595 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 21 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-7595 exists.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.10.8
- nokogiri (RubyGems): affected all versions; fixed in 1.10.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7595/ (Markdown: https://insights.sbomify.com/CVE-2020-7595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7595
- OSV: https://osv.dev/vulnerability/CVE-2020-7595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7595/
Summaries are generated and may contain mistakes; the official description above is the record.
