# CVE-2020-7596: Improper Neutralization of Special Elements in Output Used by a Downstream Component in Codecov

> Remote attackers can execute arbitrary commands via the gcov-args argument in the Codecov npm module.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mh2h-6j8q-x246

## What is CVE-2020-7596?

CVE-2020-7596 is a high-severity command injection vulnerability in codecov npm module, published on 25 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Codecov npm module before 3.6.2 allows remote attackers to execute arbitrary commands via the "gcov-args" argument.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-7596?

2 open source packages ship an affected version, including codecov. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codecov` | npm | All versions | 3.6.2 |
| `codecov` | npm | All versions | 3.6.2 |

Products: Codecov Nodejs Uploader.

## How do I fix CVE-2020-7596?

Upgrade codecov to 3.6.2 or later.

## Is CVE-2020-7596 being exploited?

There is no known exploitation of CVE-2020-7596 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7596 and fix it if it is affected.

What it is: CVE-2020-7596 is a high-severity command injection vulnerability in codecov npm module, published on 25 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7596 in the wild and no public exploit code.

Affected packages and fixed versions:
- codecov (npm): affected all versions; fixed in 3.6.2
- codecov (npm): affected all versions; fixed in 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7596/ (Markdown: https://insights.sbomify.com/CVE-2020-7596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7596
- OSV: https://osv.dev/vulnerability/CVE-2020-7596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7596/
Summaries are generated and may contain mistakes; the official description above is the record.
