# CVE-2020-7597: codecov NPM module allows remote attackers to execute arbitrary commands

> Remote attackers can execute arbitrary commands via the gcov-root argument in the codecov-node npm module.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5q88-cjfq-g2mh, SNYK-JS-CODECOV-548879

## What is CVE-2020-7597?

CVE-2020-7597 is a high-severity command injection vulnerability in codecov npm module, published on 17 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

codecov-node npm module before 3.6.5 allows remote attackers to execute arbitrary commands.The value provided as part of the gcov-root argument is executed by the exec function within lib/codecov.js. This vulnerability exists due to an incomplete fix of CVE-2020-7596.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-7597?

2 open source packages ship an affected version, including codecov. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codecov` | npm | All versions | 3.6.5 |
| `codecov` | npm | All versions | 3.6.5 |

Products: Codecov Codecov.

## How do I fix CVE-2020-7597?

Upgrade codecov to 3.6.5 or later.

## Is CVE-2020-7597 being exploited?

There is no known exploitation of CVE-2020-7597 in the wild and no public exploit code.

## Other vulnerabilities in codecov npm module

- [CVE-2020-15123](https://insights.sbomify.com/CVE-2020-15123/): Command injection in codecov (npm package) (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7597 and fix it if it is affected.

What it is: CVE-2020-7597 is a high-severity command injection vulnerability in codecov npm module, published on 17 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7597 in the wild and no public exploit code.

Affected packages and fixed versions:
- codecov (npm): affected all versions; fixed in 3.6.5
- codecov (npm): affected all versions; fixed in 3.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7597/ (Markdown: https://insights.sbomify.com/CVE-2020-7597/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7597
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7597
- OSV: https://osv.dev/vulnerability/CVE-2020-7597

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7597/
Summaries are generated and may contain mistakes; the official description above is the record.
