# CVE-2020-7610: Deserialization of Untrusted Data in bson

> Attackers can exploit improper deserialization in the BSON library to potentially execute arbitrary code by manipulating object types.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-7610, GHSA-v8w9-2789-6hhr, ROOT-APP-NPM-CVE-2020-7610, SNYK-JS-BSON-561052, UBUNTU-CVE-2020-7610

## What is CVE-2020-7610?

CVE-2020-7610 is a critical unsafe deserialization vulnerability in bson, published on 30 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of bson before 1.1.4 are vulnerable to Deserialization of Untrusted Data. The package will ignore an unknown value for an object's _bsotype, leading to cases where an object is serialized as a document rather than the intended BSON type.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-7610?

2 open source packages ship an affected version, including bson. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bson` | npm | All versions | 1.1.4 |
| `bson` | npm | All versions | 1.1.4 |

Products: Mongodb Bson.

## How do I fix CVE-2020-7610?

Upgrade bson to 1.1.4 or later.

## Is CVE-2020-7610 being exploited?

There is no known exploitation of CVE-2020-7610 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7610 and fix it if it is affected.

What it is: CVE-2020-7610 is a critical unsafe deserialization vulnerability in bson, published on 30 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7610 in the wild and no public exploit code.

Affected packages and fixed versions:
- bson (npm): affected all versions; fixed in 1.1.4
- bson (npm): affected all versions; fixed in 1.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7610/ (Markdown: https://insights.sbomify.com/CVE-2020-7610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7610
- OSV: https://osv.dev/vulnerability/CVE-2020-7610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7610/
Summaries are generated and may contain mistakes; the official description above is the record.
